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SESSION 1:  
Analyze data using scenarios and goal seek 

Consolidating data  

 

Data > Consolidate provides a graphical interface for copying data from one range of 

cells to another, then running one of a dozen functions on the data. During consolidation, 

the contents of cells from several sheets can be combined in one place. 
 

1) Open the document that contains the cell ranges to be consolidated. 

 

2) Choose Data > Consolidate to open the Consolidate dialog (Figure 1). 
 

 

Figure 1: Defining the data to be consolidated 
 

3) If the Source data range list contains named ranges, you can select a source 

cell range to consolidate with other areas. 

If the source range is not named, click in the field to the right. and either type a 

reference for the first source data range or use the mouse to select the range on the 

sheet. (You may need to move the Consolidate dialog to reach the required cells.) 

4) Click Add. The selected range now appears on the Consolidation ranges list. 

5) Select additional ranges and click Add after each selection. 

6) Specify  where you want to display the result by selecting a target range from the 



 

Copy results to box. 

If the target range is not named, click in the field next to Copy results to and enter 

the reference of the target range or select the range using the mouse or position the 

cursor in the top left cell of the target range. 

7) Select a function from the Function list. The function specifies how the values of 

the consolidation ranges are linked. The Sum function is the default setting. 

 

Most of the available functions are statistical (such as AVERAGE, MIN, MAX, 

STDEV), and the tool is most useful when you are working with the same data over 

and over. 

8) Optionally  click More in the Consolidate dialog to display additional 

settings. 

Å Select L ink  to source data to insert the formulas that generate the results in 

the target range, rather than the actual results. If you link the data, any values 

modifi ed in the source range are automatically  updated in the target range. The 

corresponding cell references in the target range are inserted in consecutive 

rows, which are automatically  ordered and then hidden from view. Only the 

final result, based on the selected function, is displayed. 

Å Under Consolidate by, select either Row labels or Column labels if  the cells of the 

source data range are not to be consolidated corresponding to the identical 

position of the cell in the range, but instead according to a matching row label or 

column label. To consolidate by row labels or column labels, the label must be 

contained in the selected source ranges. The text in the labels must be identical, 

so that rows or columns can be accurately matched. If the row or column label 

does not match any that exist in the target range, it will  be appended as a new 

row or column. 
 

9) Click OK to consolidate the ranges. 
 

If you are continually  working with the same range, then you probably want to use Data > 

Create Range to give it a name. 
 

The data from the consolidation ranges and target range are saved when you save the 

document. If you later open a document in which consolidation has been defined, this data 

will  again be available. 
 

 

Creating subtotals 

SUBTOTAL is a function listed under the Mathematical category when you use the Function 

Wizard (Inser t > Function). Because of its usefulness, the function has a graphical interface 

accessible from Data 

> Subtotals. 
 

As the name suggests, SUBTOTAL totals data arranged in a arrayðthat is, a group of cells 

with labels for columns and/or rows. Using the Subtotals dialog, you can select arrays, and 

then choose a statistical function to apply to them. For efficiency, you can choose up to three 



 

groups of arrays to which to apply a function. When you click OK , Calc adds 

subtotals and grand totals to the selected arrays, using the Result and Result2 cell 

styles for them. 
 

To insert subtotal values into a sheet: 
 

1) Ensure that the columns have labels. 

2) Select the range of cells that you want to calculate subtotals for, and then 

choose Data > Subtotals. 

3) In the Subtotals dialog (Figure 2), in the Group by box, select the column that 

you want to add the subtotals to. If the contents of the selected column 

change, the subtotals are automatically  recalculated. 

4) In the Calculate subtotals for  box, select the columns 

containing the values that you want to subtotal. 

5) In the Use function box, select the function that you want to use to calculate 

the subtotals. 

6) Click OK . 
 

 

Figure 2: Sett ing up subtotals 



 

If you use more than one group, then you can also arrange the subtotals according to 

choices made on the dialogôs Options page (Figure 3), including ascending and 

descending order or using one of the predefined custom sorts defined in Tools > 

Options > OpenOffi ce.org Calc > Sort  L ists. 

 

 

Figure 3: Choosing options for  subtotals 

 

Using ñwhat ifò scenarios 

Scenarios are a tool to test ñwhat-ifò questions. Use Tools > Scenari os to enter variable 

contentsðscenariosðin the same cell. Each scenario is named, and can be edited and 

formatted separately, and chosen from a drop-down list in the Navigator and the title bar of 

the scenario. When you print the spreadsheet, only the contents of the currently active 

scenario are printed. 
 

By adding a scenario, you can quickly change the arguments of a formula and view the 

new results. For example, if  you wanted to calculate different interest rates on an 

investment, you could add a scenario for each interest rate, and quickly view the results. 

If you had another formula that calculated your yearly income and included the result of 

the interest rate formula as an argument, it would also be updated. If all  your sources of 

incomes used scenarios, you could effi ciently build a complex model of your possible 

income.



 

 

 

Creating scenarios 
 

To create a scenario, select all  the cells that provide the data for the scenario. 
 

1) Select the cells that contain the values that will change between scenarios. To 

select multiple cells, hold down the Ctrl key as you click each cell. 

2) Choose Tools > Scenarios. 

3) On the Create Scenario dialog (Figure 4), enter a name for the new scenario. Itôs 

best to use a name that clearly identif ies the scenario, not the default name as 

shown in the illustration. This name is displayed in the Navigator and on the title 

bar of the scenario on the sheet itself. 
 

 

Figure 4: Creating a scenario  
 

4)  Optionally  add some information to the Comment box. The 

example shows the default comment. This information is 

displayed in the Navigator when you click the Scenarios icon and 

select the desired scenario



 

. 

5) Optionally select or deselect the options in the Settings section. 

See below for more information about these options. 

6) Click OK to close the dialog. The new scenario is automatically  activated. 
 

 

Settings 

 

The lower portion of the Create Scenario dialog contains several options. In most cases the 

default settings (shown selected in the example) are suitable. 
 

Display border 

Highlights the scenario in your table with a border. The color for the border is specified 

in the field to the right of this option. The border has a title bar displaying the name of 

the last scenario. The button on the right of the scenario border offers you an overview 

of all  the scenarios in this area, if  several have been defined. You can choose any of the 

scenarios from this list without restrictions. 
 

Copy back 

Copies the values of cells that you change into the active scenario. If you do not select 

this option, the scenario is not changed when you change cell values. The behavior of the 

Copy back setting depends on the cell protection, the sheet protection, and the Prevent 

changes settings. 
 

Copy entire  sheet 

Copies the entire sheet into an additional scenario sheet. 
 

Prevent changes 

Prevents changes to the active scenario. 

Å You can only change the scenario properties if the Prevent changes option is not 

selected and if the sheet is not protected. 

Å You can only edit cell values if the Prevent changes option is selected, if the 

Copy back option is not selected, and if the cells are not protected. 

Å You can only change scenario cell values and write them back into the scenario if  the 

Prevent changes option is not selected, if  the Copy back option is selected, and if 

the cells are not protected. 



 

Working with scenarios using the Navigator 
 

After scenarios are added to a spreadsheet, you can jump to a particular scenario by 

using the Navigator, then selecting a scenario from the list. You can also color code 

scenarios to make them easier to distinguish from one another. 
 

To select a scenario in the Navigator, click the Scenarios icon in the Navigator. The 

defined scenarios are listed, with the comments that were entered when the scenarios 

were created. 
 

 

Figure 5: Scenari os in the Navigator  
 

Double-click a scenario name in the Navigator to apply that scenario to the current 

sheet. 
 

To delete a scenario, right-click the name in the Navigator and choose 

Delete. 
 

To edit a scenario, including its name and comments, right-click the name in the 

Navigator and choose Properties. The Edit Properties dialog is the same as the 

Create Scenario dialog (Figure 4). 
 

To learn which values in the scenario affect other values, choose Tools 

> Detective > Trace Dependents. Arrows point to the cells that are directly 

dependent on the current cell. 



 

Providing alternate versions of formulas 

Like scenarios, Data > Multi ple Operations is a planning tool for ñwhat ifò 

questions. Unlike a scenario, the Multiple Operations tool does not present the 

alternate versions in the same cells or with a drop-down list. Instead, the Multiple 

Operations tool creates a formula array: a separate set of cells that give all  the 

alternative results for the formulas used. Although the tool is not listed among the 

functions, it is really  a function that acts on other functions, allowing you to calculate 

different results without having to enter and run them separately. 
 

To use the Multiple Operations tool, you need two arrays of cells. The first array 

contains the original or default values and the formulas applied to them. The formulas 

must be in a range. 
 

The second array is the formula array. It is created by entering variablesðalternative 

valuesðfor one or two of the original values. Once the variable values are created, you 

use the Multiple Operations tool to specify  the formulas you are using, as well  as the 

original values altered by the variables. The result is the outcome of the formulas using 

each variable. 
 

The Multiple Operations tool can use any number of formulas, but only one or two 

variables. With one variable, you add diff erent values for the variables as column or 

row labels. You then add a column to the right of the column labels or a row below the 

row labels (whichever you are using) for the results of each formula using the variable 

values. With two variables, the values for one variable are used as column labels, and 

the values for the other variable as row labels. 
 

Setting up multiple operations can be confusing at first. For example, when using 

two variables, you need to select them carefully, so that they form a meaningful table. 

Not every pair of variables is useful to add to the same formula array. Yet, even when 

working with a single variable, a new or tired user can easily make mistakes or forget 

the relation between cells in the original array and cells in the formula array. In 

these situations, Tools > Detective can help to clarify  the relations. 
 

You can also make formula arrays easier to work with if you apply  some simple design 

logic Place the original and the formula array close together on the same sheet, and use 

labels for the rows and columns in both. These small  exercises in organizational design 

will  make working with the formula array much less painful, particularly when you 

are correcting mistakes or adjusting results. 

 
 

  

Multiple operations in columns or  rows 

 

In your spreadsheet, enter a formula to calculate a result from values that are stored in 

other cells. Then, set up a cell range where you enter some fixed values, and the 

Multiple Operations command will calculate the results depending on the formula. 
 

In the Formula field, enter the cell reference to the formula that applies to the data 

range. In the Column input cell/Row input cell field, enter the cell reference to the 

corresponding cell that is part of the formula. This can be explained best by examples. 



 

(Cell references correspond to those in the following figures.) 
 

Letôs say you produce toys that you sell for $10 each (cell  B1). Each toy costs $2 to 

make (cell B2), in addition to which you have fixed costs of $10,000 per year (cell 

B3). How much profit will  you make in a year if  you sell a particular number of toys? 
 

 

Calculating with one formula and one variable 

1) To calculate the profi t, fi rst enter any number as the quantity (items sold); in 

this example, 2000 (cell B4). The profit  is found from the formula 

Profi t=Quantity *  (Selli ng price ï Direct costs) ï Fixed costs. Enter this formula 

in B5: =B4*(B1-B2)-B3. 

2) In column D enter given annual sales, one below the other; for example, 

500 to 5000, in steps of 500. 

3) Select the range D2:E11, and thus the values in column D and the empty cells 

alongside in column E. 

4) Choose Data > Multi ple Operations. 

5) With the cursor in the Formulas field of the Multiple operations dialog, 

click cell B5. 

6) Set the cursor in the Column input cell field and click cell B4. This means that 

B4, the quantity, is the variable in the formula, which is replaced by the selected 

column values. Figure 6 shows the worksheet and the Multiple operations 

dialog. 

7) Click OK . The profi ts for the different quantities are now shown in column 

E. See Figure 7. 



 

 

Figure 6: Sheet and Multiple operations dialog showing input 
 

 

 

Figure 7: Sheet showing results of multiple operations calculations 
 

 

 

 

 

  



 

 

Tip 

You may find it easier to mark the required reference in the sheet if you click 

the Shrink icon to reduce the Multiple operations dialog to the size of the 

input field. The icon then changes to the Maximize icon; click it to restore 

the dialog to its original size. 

Calculating with several formulas simultaneously 

1) In the sheet from the previous example, delete the contents of column E. 

2) Enter the following formula in C5: =B5/B4. You are now 

calculating the annual profit  per item sold. 

3) Select the range D2:F11, thus three columns. 

4) Choose Data > Multi ple Operations. 

5) With the cursor in the Formulas field of the Multiple operations dialog, 

select cells B5 thru C5. 

6) Set the cursor in the Column input cell field and click cell B4. 

Figure 8 shows the worksheet and the Multiple operations dialog. 
 

 

Figure 8: Sheet and dialog showing input 
 

 

7) Click OK . Now the profits are listed in column E and the annual profit  per 

item in column F. See Figure 9. (You might want to format column F to show 

2 decimal points, for easier comparison of the amounts.) 



 

 

Figure 9: Results of multiple operations calculations 
 

 

Multiple operations across rows and columns 

 

You can carry out joint multiple operations for columns and rows in so- called cross-

tables. The formula cell must refer to both the data range arranged in rows and the one 

arranged in columns. Select the range defined by both data ranges and call  the 

multiple operation dialog. Enter the reference to the formula in the Formula field. The 

Row input cell and the Column input cell fields are used to enter the reference to the 

corresponding cells of the formula. 
 

 

Calculating with two variables 

You now want to vary not just the quantity produced annually, but also the selling 

price, and you are interested in the profit  in each case. 
 

Expand the table shown above. D2 thru D11 contain the numbers 500, 1000 and so on, 

up to 5000. In E1 through H1 enter the numbers 8, 10, 15 and 20. 
 

1) Select the range D1:H11. 

2) Choose Data > Multi ple Operations. 

3) With the cursor in the Formulas field of the Multiple operations dialog, 

click cell B5 (profi t). 

4) Set the cursor in the Row input cell field and cli ck cell B1. This means that 

B1, the selling price, is the horizontally  entered variable (with the values 8, 

10, 15 and 20). 

5) Set the cursor in the Column input cell field and click cell B4. This means that 

B4, the quantity, is the vertically  entered variable. 



 

 

Figure 10: Sheet and dialog showing input 
 

6) Click OK . The profi ts for the different selli ng prices are now shown in 

the range E2:H11. 
 

 

Figure 11: Results of multiple operations calculations 

 

Working backwards using Goal Seek 

 

Tools > Goal Seek reverses the usual order for a formula. Usuall y, you run a formula 

to get the result when certain arguments are entered. By contrast, with Goal Seek, 

you work with a completed formula to see what values you need in an argument to get 

the results that you want. 
 

To take a simple example, imagine that the Chief Financial Officer of a company is 

developing sales projections for each quarter of the forthcoming year. She knows what 

the companyôs total income must be for the year to satisfy stockholders. She also has a 

good idea of the companyôs income in the first three quarters, because of the contracts 

that are already signed. For the fourth quarter, however, no definite income is 

available. So how much must the company earn in Q4 to reach its goal? To answer, the 

CFO enters the projected earnings for each of the other three quarters and the 

projection for the entire year. Then she runs a goal seek on the cell for Q4 sales, and 

receives her answer. 



 

 

Other uses of goal seek may be more complicated, but the method remains the same. To 

run a goal seek, at least one of the values for an argument must be a referenced cell or 

range. Only one argument can be altered in a single goal seek. After you get the result of 

a goal seek, you can replace the original value in the referenced cell with the result, or 

record the result elsewhere for later use, possibly as a scenario. 
 

With the help of Goal Seek you can calculate a value that, as part of a formula, leads to the 

result you specify  for the formula. You thus define the formula with several fixed values 

and one variable value and the result of the formula. 
 

 

Goal Seek example 

 

To calculate annual interest (I), create a table with the values for the capital (C), 

number of years (n), and interest rate (i). The formula is I = C*n* i. 
 

Let us assume that the interest rate i of 7.5% and the number of years n (1) will remain 

constant. However, you want to know how much the investment capital C would have to 

be modifi ed in order to attain a particular return I. For this example, calculate how much 

capital C would be required if you want an annual return of $15,000. 
 

Enter each of the values for Capital C (an arbitrary value like 

$100,000), number of years n (1), and interest rate i (7.5%) in one cell each. Enter the 

formula to calculate the interest I in another cell. Instead of C, n, and i use the reference 

to the cell with the corresponding value. In our example, these are B1, B2, and B3. 
 

1) Place the cursor in the formula cell (the cell containing the interest I), 

and choose Tools > Goal Seek. 

2) On the Goal Seek dialog, the correct cell is already entered in the Formula cell field. 

3) Place the cursor in the Variable cell field. In the sheet, click in the cell that contains 

the value to be changed, in this example it is the cell with the capital value C. 
 

4) Enter the desired result of the formula in the Target value field. In this example, 

the value is 15000. Figure 12 shows the cells and fields. 
 



 

 

Figure 12: Example setup for  goal seek 
 

5) Click OK . A dialog appears informing you that the Goal Seek was successful. 

Click Yes to enter the result in the cell with the variable value. The result is 

shown in Figure 13. 
 

 

Figure 13: Result  of goal seek operation 
 

 

Using the Solver 

Tools > Solver amounts to a more elaborate form of Goal Seek. The difference is that 

the Solver deals with equations with multiple unknown variables. It is specifi cally  

designed to minimize or maximize the result according to a set of rules that you 

define. 
 

Each of these rules sets up whether an argument in the formula should be greater than, 

lesser than, or equal to the figure you enter. If you want the argument to remain 

unchanged, you enter a rule that the cell that contains it should be equal to its current 

entry. For arguments that you would like to change, you need to add two rules to define 

a range of possible values: the limiting conditions. For example, you can set the 

constraint that one of the variables or cells must not be bigger than another variable, or 

not bigger than a given value. You can also define the constraint that one or more 

variables must be integers (values without decimals), or binary values (where only 0 

and 1 are allowed). 



 

 

Once you have finished setting up the rules, you can adjust the argument and the 

results by clicking the Solve button. 
 

 

Figure 14: The Solver dialog 

 

 

  



 

Letôs Practice 

 

1. A student is planning her goals about the marks she should attain in the forthcoming 

Semester 4 examinations in order to achieve a distinction (75%). Assuming that examination of 

each subject is for 100 marks, her marks of the previous semesters are given as under. 
 

 Subject 1 Subject 2 Subject 3 Subject 4 
Semester 1 82 67 53 87 
Semester 2 88 78 76 69 
Semester 3 89 85 91 67 

 

Find out how many marks should she obtain in 4th semester to secure distinction. 
 

2. A business owner wants to decide if he should try to increase the sales a product or price of 

an existing product in order to increase the profit by 10%. 
 

Current Sales 82 
Cost per Unit 75 
Profit per unit 12 

 

The owner believes that he can either increase sales by 5 units without incurring additional costs 

while the price can be increased by Rs 8 without affecting the sales. 
 

 

3. The current profit situation of a business owner is as follows. 
 

Current Sales 82 
Cost per Unit 75 
Profit per unit 12 

 

Using the scenario manager, find the effect of in the new profit in case of the following situations. 
 

a. Sales = 70 and cost = 80 

b. Sales = 90 and cost = 72 

c. Sales = 85 and cost = 80 

d. Sales = 65 and cost = 80 

 

  



 

SESSION 2: 
 
Link Data and Spreadsheets 
 
Using Multiple Workbooks and Linking Cells 
 
 
RELEVANT Knowledge 

 

Spreadsheet also allows you to link the cells from various worksheets and from various spread 

sheets to summarize data from several sources. In this manner, you can create formulas that span 

different sources and make calculations using a combination of local and linked information. 

Multiple sheets help keep information organized; 

 

Setting up multiple sheets 

Identifying sheets 

When you open a new spreadsheet it has, by default, it has a sheet named Sheet1 which is managed using 

tabs at the bottom of the spreadsheet, as shown below.  

 

Inserting new sheets 

There are several ways to insert a new sheet. The first step, in all cases, is to select the sheet that 

will be next to the new sheet. Then do any of the following:  

¶ Select the   plus icon at the bottom of the screen. 

¶ Or, select Home > Insert > Insert Sheet. 



 

 
 

Renaming Worksheets 

At the bottom of each worksheet window is a small tab that indicates the name of the worksheets in 

the workbook. These names (Sheet1, Sheet2, Sheet3, and so on) are not very descriptive; you might 

want to rename your worksheets to reflect what they contain. For instance, if your workbook 

contains Students Marks in individual Subject then you may want to rename the worksheets as 

Subject names such as English, Mathematics and Social Science etc. 

There are three ways you can rename a worksheet, and the only difference between them is the way 

in which you start the renaming process. You can do any of the following: 

¶ Double-click on one of the existing worksheet names. 

¶ Right-click on an existing worksheet name, then choose Rename from the resulting Context 

menu. 

¶ Select the worksheet you want to rename (click on the worksheet tab) and then select the 

Sheet option from the Format menu. This displays a submenu from which you should select 

the Rename option. 

 

Create or change a cell reference 

A cell reference refers to a cell or a range of cells on a worksheet and can be used to find the 

values or data that you want formula to calculate. 

In one or several formulas, you can use a cell reference to refer to: 

¶ Data from one or more contiguous cells on the worksheet. 

¶ Data contained in different areas of a worksheet. 

¶ Data on other worksheets in the same workbook. 

 

Creating reference to other sheets 

You can refer to cells that are on other worksheets in the same workbook by prepending the 

name of the worksheet followed by an exclamation point (!) to the start of the cell reference. In 

the following example, the worksheet function named AVERAGE calculates the average value 

for the range B1:B10 on the worksheet named Marketing in the same workbook. 



 

 

1. Refers to the worksheet named Marketing 

2. Refers to the range of cells between B1 and B10, inclusively 

3. Separates the worksheet reference from the cell range reference 

Click the cell in which you want to enter the formula. 

In the formula bar , type = (equal sign) and the formula you want to use. 

Click the tab for the worksheet to be referenced. 

Select the cell or range of cells to be referenced. 

Referencing other sheets 

There are two ways to reference cells in other sheets: by entering the formula directly using the 

keyboard or by using the mouse. We will look at the mouse method first. 

Consider the example mentioned below:- 

 On the Total Sale sheet, set up a place for all four salesman Total Sales, so we know where to 

put the cell reference. The figure below shows a Total Sale sheet with a Sale column. We want 

to place the reference for the checking total Sale Month in cell B3. 

 

 

To make the cell reference in cell B3, select the cell and follow these steps. 



 

1. Type = in the formula bar, type sum and click on the sheet tab for the sheet containing the cell to be 

referenced. In this case, it is January sheet as shown below. 

 

2. Click on cell B2 (where January sale for Ajay is) in the January sheet. The phrase 

=SUM(January!B2 should appear in the input line as shown below 

1. Repeat the Steps for February and March. Click the green checkmark in the input line to finish. 

2. The Total Sale should now look like the figure below 

 

 

Creating the reference with the keyboard 

From the figure above, you can deduce how the cell reference is constructed. The reference has two parts: 

the sheet name (Januaryô) and the cell reference (B2). Notice that they are separated by a period.  

Note: The sheet will be in single quotes because it contains a space, and the mandatory period (.) always 

falls outside any quotes.  

Working with Hyperlinks 

1. On a worksheet, click the cell where you want to create a hyperlink. 

You can also select an object, such as a picture or an element in a chart that you want to use 

to represent the hyperlink. 

On the Insert tab, in the Links  group, click Hyperlink . 

You can also right-click the cell or graphic and then click Hyperlink  on the shortcut menu, 

or you can press Ctrl+K. 



 

2. Under Link to, click Create New Document. 

3. In the Name of new document box, type a name for the new file. 

 

 

4. Under When to edit, click Edit the new document later or Edit the new document now to 

specify when you want to open the new file for editing. 

5. In the Text to display box, type the text that you want to use to represent the hyperlink. 

6. To display helpful information when you rest the pointer on the hyperlink, click ScreenTip, 

type the text that you want in the ScreenTip text box, and then click OK. 

 

Session 3: 

Sharing Worksheet Data 
Relevant Knowledge 

 
In most office settings, there is a shared drive where teams can store common files for 

everyone to use. This usually leads to sighting of the message: ñThe document [file name] is 

locked for editing by another user. To open a read-only copy of this document, clickñ!! This 

message appears because someone else already has the file open. Sometimes however, it is 

necessary to have multiple people working on a file at the same time. This can be to either 

speed up data entry or simply make things easier for collaboration purposes. 

 

Spreadsheet software allows the user to share the workbook and place it in the network 

location where several users can access it simultaneously. in this exercise, you will learn how to 



 

share a worksheet. 
 

 

open a new spreadsheet and type the following. 
 

 

 

Now to share the spreadsheets do the following. 

 

• Click on Share workbook option under Changes group in the Review tab. 

 
Å A dialog box appears as shown below. 

 

¶ Check the option Allow changes by more than one user at the same time. This also allows 

workbook merging. 

¶ Click OK. 
 

Note: Most spreadsheets software automatically turns off some features in shared work books. 

This is to simplify the workbook since multiple people can be working on the file at the same 



 

time. For example, shared workbooks donôt allow merging cells, conditional formatting, or 

inserting pictures/graphs/etc. 

Perform the following activity till you are confident: 
 

S.No. Activity 

1. Share worksheet data with other users. 

 

 

Assessment  

 
Fill in the blanks: 

 

1. Share Workbook option is available in group under the Review tab. 
 

2. Shared  workbooks don’t allow ,  & inserting 

 or . 

 
  



 

 

Session 4: 

Create and use Macros in Spreadsheet 

Macros are a very useful feature of Excel. 

It helps in saving time in cases when same set of tasks are to be done repeatedly like formatting or 

applying similar formula in similar range of data. 

In excel, macros can be used to name and record a set of actions or set of actions. These named set 

of recorded can be used again and again. The macros (recorded set of actions) are stored in the 

same workbook in which you created. 

In order to use a macro, we need to create a macro first. 

Let us take an example: 

 

 

To create a macro for calculating the average, minimum and maximum in each subject,  

1. Click on the developer tab. 

2. Select the first value in the list of marks. 

 

 



 

3. Now select the option  to give the respective location from where the 

steps would be followed. 

4. Now click on the option (just above . 

5. Following Record Macro dialog window appears on the 

screen. 

 

6. Give a name to your macro in the Macro name area and 

press OK. 

 

7. A keyboard shortcut may also be defined. For example in 

the example the shortcut key defined is CTRL +t. 

 

8. Select ‘This Workbook’ in ‘Store Macro In’ option. 

 

9. Click ok. 

 

10. Now click on the cell for calculating average 

of English ( E16 in this example) and write the 

formula for adding the values 

 

 

 

 

 

 

11. Similarly, write the formula for minimum and 

maximum as shown in the figure. 

 

 
 

12. Do some formatting in the appearance of the cells as shown in the example. Give some background 

colour of the cell to highlight the cell as shown  



 

 
13. Click the button óStop Recordingô in Developer tab to complete the macro recording. The 

macro names óMacro8ô in the example has been saved. 

14. To apply same formatting and have similar calculations for other subjects, click on the first 

value of other subject as shown

 



 

 

15. Click on  icon to set the relative position of cells where formula is to be 

applied. 

16. Click on the Macro button  and a dialog window 

showing the existing macros will appear. 

17. Select the option Macro8 from the list and press Run button

. 

18. On clicking the button, the average, minimum and maximum 

of marks in Hindi will be calculated and formatted according 

to the recording done in macro. 

19. Similarly run the macro using shortcut key Ctrl + t, by placing 

the cursor on the math subject marks. 

20. Now you can run the macro either using the shortcut or using the mouse selection method.  

21. Click on Edit button to make any changes within the macro. 

  Writing formula/ equations in MS Word 

Writing equations in the MS –word while typing the equations or mathematical expression can be easily 

done using Equation option on Symbols Group under Insert Tab. 

To write a mathematical expression, click on    under Insert tab and the following window 

appears: 

 

Under the equation tools a wide range of options for writing equations are available. Select  

is used to choose the type of fraction  

 

Select the appropriate type and  

 

Click on the ‘type equation here’ area to write the equation. 

 

 



 

is used for different types of superscripts and subscript.              

provides with the available options to type a radical.  

Similarly there are options for integral equations, summation, pi equations, trigonometric functions etc. 

 

 


